Grooveshark en tu desktop

Desde hacía rato había andado buscando una aplicación que resolviera con este servicio para escuchar música en streaming. Hablo de Grooveshark. Y creo que antes probé con gSharkDown, pero tuve problemas con dependencias que aún no estaban en los repos de Fedora.

Paseándome por los blogs en wordpress con etiqueta de Linux, me topé con éste post que me abrió la curiosidad de hacer un nuevo intento. Me descargué el .rpm y lo instalé, pero luego de eso me sucede lo clásico con paquetes de terceras partes: no corre, no pasa . Entonces me voy a la Terminal y lo intento correr desde ahí, pues para darme cuenta que es eso, las dependencias irresueltas.

You don't have python-appindicator installed!
StautsIcon will be used instead
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
You need to install pylast: sudo pip install pylast
You don't have python-configobj installed!

Por lo que procedí a…

$ sudo yum install pylast python-configobj

Para Fedora no existe el paquete python-appindicator, pero no es una parte vital, porque así logra correr y además ponernos un ícono en la barra de estado.

Mi interés era escuchar música de Grooveshark, pero lo mejor es que además la puedo descargar.

Descargar | gSharkDown

5 comentarios en “Grooveshark en tu desktop

  1. Buenas!
    Ante todo muchas gracias por pasarte por mi blog y difundirlo en el tuyo. Por lo que leo usas Fedora, siento no haber probado como instalarlo en Fedora, por lo que he leído del error te dice que un snippet que usa python no está instalado y que se utiliza StatusIcon en su lugar, si has instalado las demás dependencias no creo que te lance ninguna excepción.

    Me alegro de haberte despertado la curiosidad con mi post =)

    Salu2!

    1. Definitivamente. La aplicación corre perfectamente en Fedora 16 x86_64 bits, porque agraciadamente no es dependiente de arquitectura específica. Gracias a tu post, pues estoy usando gsharkdown. Saludos!!!

  2. hola amigo sabes yo tambien quiero usar lo tengo instalado y me aparece en la lista de las aplicaiones pero almomento de adr click no pasa nada y ya hice lo que aconsejas hasta ahi todo bien pero ahor ame salta esto y lo quiero instalar el python-appindicator y me dice nada para hacer que se puede hacer? gracias por alguna respuesta

    [root@compu-dextre vivi]# gsharkdown
    ** Message: pygobject_register_sinkfunc is deprecated (GstObject)
    You don’t have python-appindicator installed!
    StautsIcon will be used instead
    Traceback (most recent call last):
    File “gsharkdown.py”, line 76, in
    from lib.enviroment import env
    File “/usr/share/gsharkdown/lib/enviroment.py”, line 6, in
    import libproxy
    ImportError: No module named libproxy
    [root@compu-dextre vivi]# sudo yum install python-appindicator
    Complementos cargados:langpacks, presto, refresh-packagekit
    adobe-linux-i386 17/17
    google-chrome 3/3
    No existe disponible ningún paquete python-appindicator.
    Error: Nada para hacer
    [root@compu-dextre vivi]#

    1. Mira bien el post… ahí explico que en Fedora no existe el paquete python-appindicator. De todas formas no es una dependencia vital. Igual podes busca el modulo fuente y lo instalas manualmente. Saludos.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s